Microsoft Azure App Service / Web Apps - Investigating
Incident Report for Optimizely Service
Resolved
From Microsoft:
Service and App Service Linux - Multiple Regions
Summary of impact: Between 22:10 UTC on 20 Mar 2018 and 13:30 UTC on 21 Mar 2018, a subset of customers using App Service and App Service Linux in multiple regions may have experienced issues when performing Service Management functions. Errors may have included timeouts, portal blades failing to load, or failures when leveraging Service Management API's. Runtime availability for App Service was not impacted during this time.

Preliminary root cause: Engineers determined that a recent deployment task caused some backend services to experience CPU spikes, which in-turn caused some Service Management requests to fail.

Mitigation: Engineers performed a code update which optimized the execution path, and removed the CPU spike condition, thus mitigating the issue.

Next steps: Engineers will continue to investigate to establish the full root cause and prevent future occurrences.
Posted Mar 21, 2018 - 14:54 UTC
Investigating
From Microsoft: Starting at 22:10 UTC on 20 Mar 2018, a subset of customers using App Service and App Service Linux in multiple regions may experience issues when performing Service Management functions. Errors may include timeouts, the relevant portal blades failing to load, or failures when leveraging Service Management API's. Existing Web Apps are not impacted by this issue. Engineers are aware of this issue and are actively investigating.
Updates are posted on https://azure.microsoft.com/status/

This issue may impact PaaS Portal Deployments.
Posted Mar 21, 2018 - 13:27 UTC